what is the correct apache + htaccess settings


Hi all, complying with the main overview to mount 2.4 I am unable to effectively begin the store. It winds up such as this:

So, I produced the job in subfolder “store” from my paper origin/ var/www/html. As necessary I place this in my 000-default. conf of the apache configuation:

<< Directory Site "/ var/www/html/ store">> AllowOverride All<

I began the magento configuration: mount regular with localhost/shop as my base-url. That underwent winding up with an.htaccess documents in/ var/www/html/ store:

 RewriteEngine on RewriteCond % { REQUEST_URI} ! ^/ bar/.
 RewriteCond % { REQUEST_URI} ! ^/ configuration/.
 RewriteCond % { REQUEST_URI} ! ^/ upgrade/.
 RewriteCond % { REQUEST_URI} ! ^/ dev/.
 RewriteRule * / bar/$ 0 [L]
 DirectoryIndex index php

in bar, there additionally is an.htaccess however it looks extremely various.

Calling http://localhost/shop does NOT work here, it ends up with a 404. When I change my htaccess like this

 RewriteEngine on RewriteCond % { REQUEST_URI} ! ^/ bar/.
 RewriteCond % { REQUEST_URI} ! ^/ configuration/.
 RewriteCond % { REQUEST_URI} ! ^/ upgrade/.
 RewriteCond % { REQUEST_URI} ! ^/ dev/.
 RewriteRule * / store/ bar/$ 0 [L]
 DirectoryIndex index php

( see line 6 where I included/ store) I can call the store however with no web pages or web links functioning (see screenshot over).

Likewise, the admin web link is not functioning.

I currently released fixed web content, cleansed the cache as well as restore however this did not transform anything.

I presume adjusting the htaccess like I did just helps components of it. No place in the documents it is claimed to change this line nevertheless. When I leave every little thing as it wants installment it does not function. When I recognized the revise regulations properly all demand under localhost/shop need to most likely to localhost/shop/pub however this does not occur.

When I by hand go into localhost/shop/pub I can see the “Web page” with “CMS homepage web content goes right here.” as web content. Appears to be proper.

Any kind of tips right here?

Screenshot 2022-06-16 at 16.25.25.png