magento 2.4.5 installation error – Magento Forums


Hi,

Hi I am obtaining a mistake throughout setup.
magento variation: 2.4.5-p1
author: 2.5.1
ubuntu 22
nginx 1.18.0
php 8.1
all php expansions are set up
command run:
bin/magento configuration: set up
— base-url =http://123.123.123.123
— db-host= localhost
— db-name= magento
— db-user= magento
— db-password=” U274eeGzNCqKJ2LpvtS@329″
— admin-firstname= bob
— admin-lastname= smith
— admin-email=bob@example.com
— admin-user= bob
— admin-password=example@123
— language= en_US
— money= GBP
— timezone= Europe/London
— use-rewrites= 1

below is the mistake:
array_merge(): Debate # 2 has to be of kind range, string offered # 0/ var/www/html/ setup/src/Magento/ Setup/Model/ConfigModel. php( 157 ): array_merge()
# 1/ var/www/html/ setup/src/Magento/ Setup/Console/Command/ InstallCommand.php( 273 ): MagentoSetupModelConfigModel->> validate()
# 2/ var/www/html/ vendor/symfony/console/ Command/Command. php( 221 ): MagentoSetupConsoleCommandInstallCommand->> initialize()
# 3/ var/www/html/ vendor/symfony/console/ Application.php( 1021 ): SymfonyComponentConsoleCommandCommand->> run()
# 4/ var/www/html/ vendor/symfony/console/ Application.php( 275 ): SymfonyComponentConsoleApplication->> doRunCommand()
# 5/ var/www/html/ vendor/magento/framework/ Console/Cli. php( 116 ): SymfonyComponentConsoleApplication->> doRun()
# 6/ var/www/html/ vendor/symfony/console/ Application.php( 149 ): MagentoFrameworkConsoleCli->> doRun()
# 7/ var/www/html/ bin/magento( 23 ): SymfonyComponentConsoleApplication->> run()
# 8 {major}

please aid