Still cannot upgrade to Drupal 10


Complying With https://www.drupal.org/docs/upgrading-drupal/upgrading-from-drupal-8-or-…

Note: zurb_foundation has actually been covered for D10

jarfx:/ srv/www/htdocs/ ssl2/blogs # chmod 777 web/sites/default
jarfx:/ srv/www/htdocs/ ssl2/blogs # chmod 666 web/sites/default/ * settings.php
jarfx:/ srv/www/htdocs/ ssl2/blogs # chmod 666 web/sites/default/ * services.yml
jarfx:/ srv/www/htdocs/ ssl2/blogs # author need ‘drupal/core-recommended: ^ 10’ ‘drupal/core-composer-scaffold: ^ 10’ ‘drupal/core-project-message: ^ 10’– update-with-dependencies– no-update
/ composer.json has actually been upgraded
jarfx:/ srv/www/htdocs/ ssl2/blogs # author upgrade -W
Collecting spots for origin plan.
Filling author databases with plan details
Upgrading reliances
Your needs can not be settled to an installable collection of plans.

Trouble 1
– drupal/core 8.0.0-beta6 calls for doctrine/common dev-master #a 45d110f71c323e29f41eb0696fa230e3fa1b1b5 -> > located doctrine/common[dev-remove-int-cast, 2.1.3, …, 2.13.x-dev, 3.0.0, …, 3.5.x-dev] however it does not match the restraint.
– zendframework/zend-feed[dev-master, dev-develop, 2.11.0, …, 2.13.x-dev] need php ^ 5.6|| ^ 7.0 -> > your php variation (8.1.14) does not please that need.
– laminas/laminas-feed[2.12.0, …, 2.12.x-dev] need php ^ 5.6|| ^ 7.0 -> > your php variation (8.1.14) does not please that need.
– symfony/psr-http-message- bridge[v1.1.0, …, 1.1.x-dev] need php ^ 5.3.3|| ^ 7.0 -> > your php variation (8.1.14) does not please that need.
– symfony-cmf/routing[1.4.0-RC1, …, 1.4.x-dev] need php ^ 5.3.9|^ 7.0 -> > your php variation (8.1.14) does not please that need.
– symfony/psr-http-message- bridge[v1.2.0, …, v1.3.0] need php ^ 7.1 -> > your php variation (8.1.14) does not please that need.
– drupal/core[8.9.11, …, 8.9.x-dev] need php ^ 7.0.8 -> > your php variation (8.1.14) does not please that need.
– drupal/core[9.0.10, …, 9.0.x-dev] need php ^ 7.3 -> > your php variation (8.1.14) does not please that need.
– laminas/laminas-feed[2.13.0, …, 2.14.x-dev] need php ^ 7.3|| ~ 8.0.0 -> > your php variation (8.1.14) does not please that need.
– Origin composer.json calls for drupal/zurb _ structure ^6.7@beta -> > satisfiable by drupal/zurb _ structure[6.7.0-beta1]
– drupal/core-recommended 10.0.0-alpha1 calls for drupal/core 10.0.0-alpha1 -> > satisfiable by drupal/core[10.0.0-alpha1]
– Verdict: do not mount drupal/core 10.0.0-alpha1 (dispute evaluation outcome)
– drupal/core-recommended 10.0.0-alpha2 calls for drupal/core 10.0.0-alpha2 -> > satisfiable by drupal/core[10.0.0-alpha2]
– Verdict: do not mount drupal/core 10.0.0-alpha2 (dispute evaluation outcome)
– drupal/core-recommended 10.0.0-alpha3 calls for drupal/core 10.0.0-alpha3 -> > satisfiable by drupal/core[10.0.0-alpha3]
– Verdict: do not mount drupal/core 10.0.0-alpha3 (dispute evaluation outcome)
– drupal/core-recommended 10.0.0-alpha4 calls for drupal/core 10.0.0-alpha4 -> > satisfiable by drupal/core[10.0.0-alpha4]
– Verdict: do not mount drupal/core 10.0.0-alpha4 (dispute evaluation outcome)
– drupal/core-recommended 10.0.0-alpha5 calls for drupal/core 10.0.0-alpha5 -> > satisfiable by drupal/core[10.0.0-alpha5]
– Verdict: do not mount drupal/core 10.0.0-alpha5 (dispute evaluation outcome)
– drupal/core-recommended 10.0.0-alpha6 calls for drupal/core 10.0.0-alpha6 -> > satisfiable by drupal/core[10.0.0-alpha6]
– Verdict: do not mount drupal/core 10.0.0-alpha6 (dispute evaluation outcome)
– drupal/core-recommended 10.0.0-alpha7 calls for drupal/core 10.0.0-alpha7 -> > satisfiable by drupal/core[10.0.0-alpha7]
– Verdict: do not mount drupal/core 10.0.0-alpha7 (dispute evaluation outcome)
– drupal/core-recommended 10.0.0-beta1 calls for drupal/core 10.0.0-beta1 -> > satisfiable by drupal/core[10.0.0-beta1]
– Verdict: do not mount drupal/core 10.0.0-beta1 (dispute evaluation outcome)
– drupal/core-recommended 10.0.0-beta2 calls for drupal/core 10.0.0-beta2 -> > satisfiable by drupal/core[10.0.0-beta2]
– Verdict: do not mount drupal/core 10.0.0-beta2 (dispute evaluation outcome)
– drupal/core-recommended 10.0.0-rc1 calls for drupal/core 10.0.0-rc1 -> > satisfiable by drupal/core[10.0.0-rc1]
– Verdict: do not mount drupal/core 10.0.0-rc1 (dispute evaluation outcome)
– drupal/core-recommended 10.0.0-rc2 calls for drupal/core 10.0.0-rc2 -> > satisfiable by drupal/core[10.0.0-rc2]
– Verdict: do not mount drupal/core 10.0.0-rc2 (dispute evaluation outcome)
– drupal/core-recommended 10.0.0-rc3 calls for drupal/core 10.0.0-rc3 -> > satisfiable by drupal/core[10.0.0-rc3]
– Verdict: do not mount drupal/core 10.0.0-rc3 (dispute evaluation outcome)
– drupal/core-recommended 10.0.0 calls for drupal/core 10.0.0 -> > satisfiable by drupal/core[10.0.0]
– Verdict: do not mount drupal/core 10.0.0 (dispute evaluation outcome)
– drupal/core-recommended 10.0.1 calls for drupal/core 10.0.1 -> > satisfiable by drupal/core[10.0.1]
– Verdict: do not mount drupal/core 10.0.1 (dispute evaluation outcome)
– drupal/core-recommended 10.0.2 calls for drupal/core 10.0.2 -> > satisfiable by drupal/core[10.0.2]
– Verdict: do not mount drupal/core 10.0.2 (dispute evaluation outcome)
– drush/drush[11.4.0, …, 11.x-dev] dispute with drupal/core 9.1.15.
– drush/drush[11.4.0, …, 11.x-dev] dispute with drupal/core 9.1.14.
– drush/drush[11.4.0, …, 11.x-dev] dispute with drupal/core 9.1.13.
– drush/drush[11.4.0, …, 11.x-dev] dispute with drupal/core 9.1.12.
– drush/drush[11.4.0, …, 11.x-dev] dispute with drupal/core 9.1.11.
– drush/drush[11.4.0, …, 11.x-dev] dispute with drupal/core 9.1.10.
– drush/drush[11.4.0, …, 11.x-dev] dispute with drupal/core 9.1.9.
– drush/drush[11.4.0, …, 11.x-dev] dispute with drupal/core 9.1.8.
– drush/drush[11.4.0, …, 11.x-dev] dispute with drupal/core 9.1.7.
– drush/drush[11.4.0, …, 11.x-dev] dispute with drupal/core 9.1.6.
– drush/drush[11.4.0, …, 11.x-dev] dispute with drupal/core 9.1.5.
– drush/drush[11.4.0, …, 11.x-dev] dispute with drupal/core 9.1.4.
– drush/drush[11.4.0, …, 11.x-dev] dispute with drupal/core 9.1.3.
– drush/drush[11.4.0, …, 11.x-dev] dispute with drupal/core 9.1.2.
– drush/drush[11.4.0, …, 11.x-dev] dispute with drupal/core 9.1.1.
– drush/drush[11.4.0, …, 11.x-dev] dispute with drupal/core 9.1.0.
– drush/drush[11.4.0, …, 11.x-dev] dispute with drupal/core 9.1.0-rc3.
– drush/drush[11.4.0, …, 11.x-dev] dispute with drupal/core 9.1.0-rc2.
– drush/drush[11.4.0, …, 11.x-dev] dispute with drupal/core 9.1.0-rc1.
– drush/drush[11.4.0, …, 11.x-dev] dispute with drupal/core 9.1.0-beta1.
– drush/drush[11.4.0, …, 11.x-dev] dispute with drupal/core 9.1.0-alpha1.
– drush/drush[11.4.0, …, 11.x-dev] dispute with drupal/core 9.0.9.
– drush/drush[11.4.0, …, 11.x-dev] dispute with drupal/core 9.0.8.
– drush/drush[11.4.0, …, 11.x-dev] dispute with drupal/core 9.0.7.
– drush/drush[11.4.0, …, 11.x-dev] dispute with drupal/core 9.0.6.
– drush/drush[11.4.0, …, 11.x-dev] dispute with drupal/core 9.0.5.
– drush/drush[11.4.0, …, 11.x-dev] dispute with drupal/core 9.0.4.
– drush/drush[11.4.0, …, 11.x-dev] dispute with drupal/core 9.0.3.
– drush/drush[11.4.0, …, 11.x-dev] dispute with drupal/core 9.0.2.
– drush/drush[11.4.0, …, 11.x-dev] dispute with drupal/core 9.0.1.
– drush/drush[11.4.0, …, 11.x-dev] dispute with drupal/core 9.0.0.
– drush/drush[11.4.0, …, 11.x-dev] dispute with drupal/core 9.0.0-rc1.
– drush/drush[11.4.0, …, 11.x-dev] dispute with drupal/core 9.0.0-beta3.
– drush/drush[11.4.0, …, 11.x-dev] dispute with drupal/core 9.0.0-beta2.
– drush/drush[11.4.0, …, 11.x-dev] dispute with drupal/core 9.0.0-beta1.
– drush/drush[11.4.0, …, 11.x-dev] dispute with drupal/core 8.1.10.
– drush/drush[11.4.0, …, 11.x-dev] dispute with drupal/core 8.1.9.
– drush/drush[11.4.0, …, 11.x-dev] dispute with drupal/core 8.1.8.
– drush/drush[11.4.0, …, 11.x-dev] dispute with drupal/core 8.1.7.
– drush/drush[11.4.0, …, 11.x-dev] dispute with drupal/core 8.1.6.
– drush/drush[11.4.0, …, 11.x-dev] dispute with drupal/core 8.1.5.
– drush/drush[11.4.0, …, 11.x-dev] dispute with drupal/core 8.1.4.
– drush/drush[11.4.0, …, 11.x-dev] dispute with drupal/core 8.1.3.
– drush/drush[11.4.0, …, 11.x-dev] dispute with drupal/core 8.1.2.
– drush/drush[11.4.0, …, 11.x-dev] dispute with drupal/core 8.1.1.
– drush/drush[11.4.0, …, 11.x-dev] dispute with drupal/core 8.1.0.
– drush/drush[11.4.0, …, 11.x-dev] dispute with drupal/core 8.1.0-rc1.
– drush/drush[11.4.0, …, 11.x-dev] dispute with drupal/core 8.1.0-beta2.
– drush/drush[11.4.0, …, 11.x-dev] dispute with drupal/core 8.1.0-beta1.
– drush/drush[11.4.0, …, 11.x-dev] dispute with drupal/core 8.0.6.
– drush/drush[11.4.0, …, 11.x-dev] dispute with drupal/core 8.0.5.
– drush/drush[11.4.0, …, 11.x-dev] dispute with drupal/core 8.0.4.
– drush/drush[11.4.0, …, 11.x-dev] dispute with drupal/core 8.0.3.
– drush/drush[11.4.0, …, 11.x-dev] dispute with drupal/core 8.0.2.
– drush/drush[11.4.0, …, 11.x-dev] dispute with drupal/core 8.0.1.
– drush/drush[11.4.0, …, 11.x-dev] dispute with drupal/core 8.0.0.
– drush/drush[11.4.0, …, 11.x-dev] dispute with drupal/core 8.0.0-rc4.
– drush/drush[11.4.0, …, 11.x-dev] dispute with drupal/core 8.0.0-rc3.
– drush/drush[11.4.0, …, 11.x-dev] dispute with drupal/core 8.0.0-rc2.
– drush/drush[11.4.0, …, 11.x-dev] dispute with drupal/core 8.0.0-rc1.
– drush/drush[11.4.0, …, 11.x-dev] dispute with drupal/core 8.0.0-beta16.
– drush/drush[11.4.0, …, 11.x-dev] dispute with drupal/core 8.0.0-beta15.
– drush/drush[11.4.0, …, 11.x-dev] dispute with drupal/core 8.0.0-beta14.
– drush/drush[11.4.0, …, 11.x-dev] dispute with drupal/core 8.0.0-beta13.
– drush/drush[11.4.0, …, 11.x-dev] dispute with drupal/core 8.0.0-beta12.
– drush/drush[11.4.0, …, 11.x-dev] dispute with drupal/core 8.0.0-beta11.
– drush/drush[11.4.0, …, 11.x-dev] dispute with drupal/core 8.0.0-beta10.
– drush/drush[11.4.0, …, 11.x-dev] dispute with drupal/core 8.0.0-beta9.
– drush/drush[11.4.0, …, 11.x-dev] dispute with drupal/core 8.0.0-beta7.
– drush/drush[11.4.0, …, 11.x-dev] dispute with drupal/core 9.1.x-dev.
– drush/drush[11.4.0, …, 11.x-dev] dispute with drupal/core 8.1.x-dev.
– drush/drush[11.4.0, …, 11.x-dev] dispute with drupal/core 8.0.x-dev.
– drupal/core[8.4.0-alpha1, …, 8.7.7] need symfony-cmf/routing ^ 1.4 -> > satisfiable by symfony-cmf/routing[1.4.0-RC1, …, 1.4.x-dev]
– drupal/core[8.2.0-beta1, …, 8.3.x-dev] need symfony-cmf/routing ~ 1.4 -> > satisfiable by symfony-cmf/routing[1.4.0-RC1, …, 1.4.x-dev]
– drupal/core[9.0.0-alpha1, …, 9.0.0-alpha2] need symfony/psr-http-message- bridge ^ 1.2.0 -> > satisfiable by symfony/psr-http-message- bridge[v1.2.0, v1.3.0]
– drupal/core[8.7.8, …, 8.9.10] need symfony/psr-http-message- bridge ^ 1.1.2 -> > satisfiable by symfony/psr-http-message- bridge[v1.1.2, 1.1.x-dev, v1.2.0, v1.3.0]
– drupal/core[8.8.0-alpha1, …, 8.8.x-dev] need zendframework/zend-feed ^ 2.12 -> > satisfiable by laminas/laminas-feed[2.12.0, …, 2.21.x-dev], zendframework/zend-feed[2.12.0, 2.12.x-dev, 2.13.x-dev]
– Origin composer.json calls for drush/drush ^ 11.4 -> > satisfiable by drush/drush[11.4.0, 11.x-dev]
– drupal/core-recommended 10.1.x-dev calls for drupal/core 10.1.x-dev -> > satisfiable by drupal/core[10.1.x-dev]
– Verdict: do not mount drupal/core 10.1.x-dev (dispute evaluation outcome)
– drupal/zurb _ structure 6.7.0-beta1 calls for drupal/core ^ 8|| ^ 9 -> > satisfiable by drupal/core[8.0.0-beta6, …, 8.9.x-dev, 9.0.0-alpha1, …, 9.5.x-dev]
– You can just mount one variation of a plan, so just one of these can be set up: drupal/core[8.0.0-beta6, …, 8.9.x-dev, 9.0.0-alpha1, …, 9.5.x-dev, 10.0.0-alpha1, …, 10.1.x-dev]
– You can just mount one variation of a plan, so just one of these can be set up: drupal/core[8.7.0-alpha1, …, 8.9.x-dev, 9.0.0-alpha1, …, 9.5.x-dev, 10.0.0-alpha1, …, 10.1.x-dev]
– drupal/core-recommended 10.0.x-dev calls for drupal/core 10.0.x-dev -> > satisfiable by drupal/core[10.0.x-dev]
– Origin composer.json calls for drupal/core-recommended ^ 10 -> > satisfiable by drupal/core-recommended[10.0.0-alpha1, …, 10.1.x-dev]

Make use of the choice– with-all-dependencies (- W) to permit upgrades, downgrades and also eliminations for plans presently secured to particular variations.


From composer.json:

“spots”: {
“enable-patching”: real,
“drupal/zurb _ structure”: {
“D10 spot”: “https://www.drupal.org/files/issues/2023-01-09/zurb_foundation-3304155-3…
},
“drupal/simple _ image_rotate”: {
“Rector spot”: “https://www.drupal.org/files/issues/2022-07-18/simple_image_rotate.2.1.x…
},

“drupal/superfish”: {
“rector spot”: “https://www.drupal.org/files/issues/2023-01-18/3299991-drupal-10-compati…
}
},