php upgrade giving error message


drupal admin recommended php upgrade, so I did. 7.4>> 8 as well as currently its tossing this mistake at me (returning to7.4 informs me php variation is as well reduced). can you please provide a hit what to do?

Added uncaught exemption tossed while taking care of exemption.

Initial

ReflectionException: Course “DrupalCoreEventSubscriberExceptionTestSiteSubscriber” does not exist in ReflectionClass->> __ construct() ( line 30 of / home/sailbudd/core/ lib/Drupal/Core/ DependencyInjection/Compiler/RegisterEventSubscribersPass. php).

ReflectionClass->> __ construct() (Line: 30).
DrupalCoreDependencyInjectionCompilerRegisterEventSubscribersPass->> procedure() (Line: 94).
SymfonyComponentDependencyInjectionCompilerCompiler->> put together() (Line: 762).
SymfonyComponentDependencyInjectionContainerBuilder->> put together() (Line: 1322).
DrupalCoreDrupalKernel->> compileContainer() (Line: 926).
DrupalCoreDrupalKernel->> initializeContainer() (Line: 20).
DrupalCoreInstallerInstallerKernel->> initializeContainer() (Line: 476).
DrupalCoreDrupalKernel->> boot() (Line: 426).
install_begin_request() (Line: 116).
install_drupal() (Line: 48).

Added

SymfonyComponentDependencyInjectionExceptionServiceNotFoundException: You have actually asked for a non-existent solution “theme.manager”. in SymfonyComponentDependencyInjectionContainerBuilder->> getDefinition() ( line 1030 of / home/sailbudd/vendor/ symfony/dependency-injection/ContainerBuilder. php).

SymfonyComponentDependencyInjectionContainerBuilder->> getDefinition() (Line: 600).
SymfonyComponentDependencyInjectionContainerBuilder->> doGet() (Line: 558).
SymfonyComponentDependencyInjectionContainerBuilder->> obtain() (Line: 649).
Drupal:: motif() (Line: 22).
_ drupal_maintenance_theme() (Line: 506).
drupal_maintenance_theme() (Line: 1025).
install_display_output() (Line: 271).
_ drupal_log_error() (Line: 365).
_ drupal_exception_handler().